driver core, kobjects, debugfs and sysfs · Supported
Maintainers
- M Greg Kroah-Hartman <gregkh@linuxfoundation.org>
- M "Rafael J. Wysocki" <rafael@kernel.org>
- M Danilo Krummrich <dakr@kernel.org>
Paths
- F
Documentation/core-api/kobject.rst - F
Documentation/driver-api/driver-model/ - F
drivers/base/ - F
fs/debugfs/ - F
fs/sysfs/ - F
include/linux/device/ - F
include/linux/debugfs.h - F
include/linux/device.h - F
include/linux/fwnode.h - F
include/linux/kobj* - F
include/linux/ksysfs.h - F
include/linux/property.h - F
include/linux/sysfs.h - F
kernel/ksysfs.c - F
lib/kobj* - F
rust/kernel/debugfs.rs - F
rust/kernel/debugfs/ - F
rust/kernel/device.rs - F
rust/kernel/device/ - F
rust/kernel/device_id.rs - F
rust/kernel/devres.rs - F
rust/kernel/driver.rs - F
rust/kernel/faux.rs - F
rust/kernel/platform.rs - F
rust/kernel/soc.rs - F
samples/rust/rust_debugfs.rs - F
samples/rust/rust_debugfs_scoped.rs - F
samples/rust/rust_driver_platform.rs - F
samples/rust/rust_driver_faux.rs - F
samples/rust/rust_soc.rs
Last 30 days
Active reviewers (last 30 days)
-
Gary Guo <gary@garyguo.net>
4 attestations (2 Reviewed-by, 2 Suggested-by) · last on 2026-07-23 -
Danilo Krummrich <dakr@kernel.org>
2 attestations (2 Acked-by) · last on 2026-07-23 -
Alice Ryhl <aliceryhl@google.com>
1 attestation (1 Reviewed-by) · last on 2026-07-23
Recent patches
Most-recent 30 patches in this subsystem on linux-block (capped at 30), ordered by date desc.
-
WARM2d
REVIEWED: 31 (31M) [PATCH v9 01/10] rust: module: move module types into `module.rs`
2026-07-23 · Alvin Sun <hidden> -
COOLING12d
REVIEWED: 19 (19M) [PATCH v8 01/10] rust: module: move module types into `module.rs`
2026-07-13 · Alvin Sun <hidden> -
COLD31d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COLD30d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COLD32d
REVIEWED: 12 (12M) [PATCH v5] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> -
COLD33d
REVIEWED: 15 (15M) [PATCH v7 01/10] rust: module: move module types into `module.rs`
2026-06-27 · Alvin Sun <hidden> -
COLD22d
REVIEWED: 34 (33M) [PATCH v19 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-26 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD34d
REVIEWED: 34 (33M) [PATCH v18 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-25 · Andreas Hindborg <a.hindborg@kernel.org> -
COLD32d
REVIEWED: 15 (15M) [PATCH v6 01/10] rust: module: move module types into `module.rs`
2026-06-24 · Alvin Sun <hidden> -
COLD35d
[PATCH v5 1/9] rust: module: move module types into `module.rs`
2026-06-24 · Alvin Sun <hidden> -
COLD36d
[PATCH v4 1/9] rust: module: move module types into `module.rs`
2026-06-23 · Alvin Sun <hidden> -
COLD35d
REVIEWED: 34 (33M) [PATCH v17 06/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-04 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE149d
REVIEWED: 34 (33M) [PATCH v16 03/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-24 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE156d
REVIEWED: 34 (33M) [PATCH v15 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-20 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE173d
REVIEWED: 7 (7M) [PATCH v14 2/9] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-02-04 · Andreas Hindborg <a.hindborg@kernel.org> -
STALE182d
[PATCH 07/33] driver core: cpu: Convert /sys/devices/system/cpu/isolated to use HK_TYPE_DOMAIN_BOOT
2026-01-25 · Frederic Weisbecker <frederic@kernel.org> -
STALE156d
[PATCH 07/33] driver core: cpu: Convert /sys/devices/system/cpu/isolated to use HK_TYPE_DOMAIN_BOOT
2026-01-01 · Frederic Weisbecker <frederic@kernel.org> -
STALE210d
[PATCH 07/33] driver core: cpu: Convert /sys/devices/system/cpu/isolated to use HK_TYPE_DOMAIN_BOOT
2025-12-24 · Frederic Weisbecker <frederic@kernel.org> -
STALE234d
Re: [PATCH 1/2] PM: runtime: Fix I/O hang due to race between resume and runtime disable
2025-12-01 · YangYang <hidden> -
STALE234d
LANDED [PATCH 1/2] PM: runtime: Fix I/O hang due to race between resume and runtime disable
2025-11-26 · Yang Yang <hidden> -
STALE177d
[PATCH v13 2/4] rust: `AlwaysRefCounted` is renamed to `RefCounted`.
2025-11-17 · Oliver Mangold <hidden> -
STALE218d
[PATCH 07/31] driver core: cpu: Convert /sys/devices/system/cpu/isolated to use HK_TYPE_DOMAIN_BOOT
2025-11-05 · Frederic Weisbecker <frederic@kernel.org> -
STALE268d
[PATCH 5/8] firmware: don't copy kernel creds
2025-11-02 · Christian Brauner <brauner@kernel.org> -
STALE281d
[PATCH] samples: rust: debugfs: use `core::ffi::CStr` method names
2025-10-19 · Miguel Ojeda <ojeda@kernel.org> -
STALE281d
REVIEWED: 48 (48M) [RESEND PATCH v18 16/16] rust: replace `CStr` with `core::ffi::CStr`
2025-10-18 · Tamir Duberstein <tamird@kernel.org> -
STALE281d
REVIEWED: 16 (15M) [RESEND PATCH v18 07/16] rust: debugfs: use `kernel::fmt`
2025-10-18 · Tamir Duberstein <tamird@kernel.org> -
STALE281d
REVIEWED: 17 (17M) [RESEND PATCH v18 01/16] samples: rust: platform: remove trailing commas
2025-10-18 · Tamir Duberstein <tamird@kernel.org> -
STALE281d
REVIEWED: 48 (48M) [PATCH v18 16/16] rust: replace `CStr` with `core::ffi::CStr`
2025-10-18 · Alice Ryhl <aliceryhl@google.com> -
STALE281d
REVIEWED: 16 (15M) [PATCH v18 07/16] rust: debugfs: use `kernel::fmt`
2025-10-18 · Tamir Duberstein <hidden> -
STALE281d
REVIEWED: 17 (17M) [PATCH v18 01/16] samples: rust: platform: remove trailing commas
2025-10-18 · Tamir Duberstein <hidden>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
COLD32d
REVIEWED: 12 (12M) [PATCH v5] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by -
COLD30d
REVIEWED: 12 (12M) [PATCH v6] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by -
COLD31d
REVIEWED: 12 (12M) [PATCH v7] rust: aref: make `AlwaysRefCounted::inc_ref` an associated function
2026-06-28 · Trevor Chan <hidden> · 1 Reviewed-by
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE156d
[PATCH 07/33] driver core: cpu: Convert /sys/devices/system/cpu/isolated to use HK_TYPE_DOMAIN_BOOT
2026-01-01 · Frederic Weisbecker <frederic@kernel.org> -
STALE182d
[PATCH 07/33] driver core: cpu: Convert /sys/devices/system/cpu/isolated to use HK_TYPE_DOMAIN_BOOT
2026-01-25 · Frederic Weisbecker <frederic@kernel.org> -
COLD36d
[PATCH v4 1/9] rust: module: move module types into `module.rs`
2026-06-23 · Alvin Sun <hidden> -
COLD35d
[PATCH v5 1/9] rust: module: move module types into `module.rs`
2026-06-24 · Alvin Sun <hidden>